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MAIL MERGE

11.1 INTRODUCTION

A common word processing task is to produce periodic mailings to

send to different people or agencies connected to you or your

profession or your business.  The mailing features in Word can help

you to organize your address data, get it into a document, and print

it out in the desired format.  The main uses of Word’s Mail Merge

features are: You can merge a list of names and addresses to a

single letter that can be sent to different people in their names and

addresses. Create categories, a single letter with variable information

fields in it, or labels. Produce merged documents such as directory

lists, invoices, print address lists, or print addresses on envelopes

and mailing labels.

11.2 OBJECTIVES

After going through this lesson you would be able to

l create form letters, mailing labels, envelopes, or catalogs

l organize address data and merging it into a generic document

l customize a mail merge

11.3 TYPES OF DOCUMENTS IN MAIL MERGE

Mail Merge requires three types of documents: (a) Main Document,

(b) Data Source, and (c) Merge Document.
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(a) Main Document:  In a Mail Merge operation, the personalized

document (such as, a standard letter, or envelope, or mailing

label) is known as the main document.  It is the document

containing the text and graphics that stay the same for each

version of the merged document - for example, the return address

and body of a form letter.

(b) Data Source:  Data source is a file that contains the names and

addresses or any other information that vary with each version

of a mail-merge document.  For example, a list of names and

addresses for a form letter you want to send to a list of clients or

other people.

(c) Merge Document:  When you merge the main document with

data source, a third document called merge document will be

produced.  The merge document can be merged to the screen to

view letters along with addresses; or directly to the printer to

print the letters along with addresses and print addresses on

envelopes or labels; or save as some other file that can be used

later for printing.  Inserting the data or information from the

data source in the main document creates the merge document.

For example, insert the merge field «City» in a letter document

to have Word insert a city name, such as “New Delhi” that is

stored in the City data field.

11.3.1 Mail Merge Helper

The Mail Merge Helper guides you through the process of doing a

mail merge.  This involves creating and editing main document;

creating a new data source or opening an existing data file; and

merging the data source with main document.  To use Mail Merge

Helper, select Tools→→→→→Mail Merge command on the menu bar.  The

Mail Merge Helper dialog box appears.

Fig. 11.1
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11.4 CREATING A MAIN DOCUMENT

In this section you will learn how to create a main document using

Mail Merge Helper, or in your own way.  The main document is most

often a form letter.  However, it can also be a mailing label, an

envelope etc.  To create a simple letter with variable (current) date,

follow these steps:

1. Open a new document.  Select

Insert→→→→→Date and Time command on

the menu bar.  The Date and Time

dialog box appears, Select date format

and click OK in the Date and Time

dialog box.

2. Leave some space (approximately 6 to 7 lines by pressing ENTER

key) to insert addresses through merge fields later.  Do not type

any thing in this space.  We will tell you how to insert addresses

from data source through data fields later.  You can also insert

fields anywhere in the body of the letter.  The following Figure

shows an example of form letter created to send the letters to all

the students admitted for DIT programme offered by National

Open School.   We have left some space below the date to insert

name address fields of students.  The enrolment number field

also can be inserted at ‘Your enrolment number is‘ later when

data source is ready.

3. Type the body of the letter.

4. Save your document.

You can also use Mail Merge Helper to create Main Document.  Follow

these steps to do it:

Fig. 11.2

Fig. 11.3
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1. Select Tools→→→→→Mail Merge

command on the menu bar.  The

Mail Merge Helper dialog box

appears.

2. Under Main document, click

Create, and then click Form

Letters.   The Microsoft Word

dialog box appears

3. Click Active Window. The active window becomes the main

document.

Observe that when you choose this helper, the action will be same

as opening a new document to create main document.

11.5 CREATING A DATA SOURCE

If you do not have existing database information, you must create

your own data source of the fields of information that will be inserted

into the letter or any other main document.  For example, a Mail

Merge letter you have created earlier might require that you have

the following fields in address list of students as data source:  Name,

Address1, Address2, City, State, and PIN Code.  In this lesson, you

will learn on creating a data source using Mail Merge Helper or

using a Word table or importing your Excel Worksheet.

11.5.1 Creating a Data Source Using Mail Merge Helper

You can use the Mail Merge Helper to create a Microsoft Word data

source with up to 63 data fields.

Follow these steps to create a data source using Mail Merge Helper:

Open a new blank document if you have not yet created the main

document or open your existing main document.

1. Select Tools→→→→→Mail Merge command on the menu bar.  The

Mail Merge Helper dialog box appears.

l If you have opened a new blank document observe that Get

Data under Data source in the Mail Merge dialog box will

not be highlighted. Click on Create drop-down menu under

Main document and then choose Form Letters in the drop-

down menu.  The Word will ask you whether you want to

use the Active Window or New Main Document.  Click on

Active Window.  Observe that Get Data under Data source

in the Mail Merge dialog box will be highlighted now.

Fig. 11.4
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l If you have opened an existing main document observe that

Get Data under Data source in the Mail Merge dialog box

will be highlighted.

2. Under Data source, click Get Data, and then click Create Data

Source.  The Create Data Source dialog box appears.

3. In the Field names in header row box, specify the data fields

that you want to include in the data source:

l To delete a data field, click the field name in the Field names

in header row box, and then click Remove Field Name.

l To add a data field, type a new field name in the Field name:

box, and then click Add Field Name.

 

l To change the order of the data fields, click a field name in

the Field names in header row box, and then click one of

the arrow buttons.   Observe that using Field Name: box

you can add your own field names.

4. When you finish specifying the data fields, click OK.  The Save

As dialog box appears.

5. Locate the folder that you want to

save the data source in, type a file

name, and

then click Save As in the Save As

dialog box.  The Microsoft Word

dialog box appears.

6. Click Edit Data Source in

the Microsoft Word dialog

box.  The Data Form dialog

box appears.

 

 

Fig. 11.5
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7. In the Data Form dialog box, fill in the information for each data

record:

o To fill in a record, type information for a data field, and then

press ENTER to move to the next field. If you don’t want to

include information for a particular field, press ENTER to

skip the field. Don’t type spaces in the box.

o To start a new data record, click Add New.

8. When you finish entering data records, click the View Source

in the Data Form dialog box. Observe that the data records

created will appear in a table format along with Database toolbar

similar to the one shown in the Figure.  Save the data source by

clicking Save on the Standard toolbar.

9. To return to the main document, click Mail Merge Main

Document button on the Database toolbar.

11.5.2 Editing Existing Data Records

To edit the existing data records in the data source file, follow these

steps:

1. Open the data source file and then select View→→→→→

Toolbars→→→→→Database command on the menu bar.  The Database

toolbar will appear on the screen.

2. Click on Data Form  button.  The Word will display the data

source in the Data Form dialog box.

3. To locate a data record that you want to change, move to the

record number you want change its contents by clicking the

arrow keys or typing the record number; or click Find, and

then search for information that you know the record contains.

4. Edit the records that you want to change.

Fig. 11.8
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5. When you finish editing records, click View Source in the Data

Form dialog box, and then click Save button on the Standard

toolbar to save changes to the data source.

11.5.3 Add New Data Records

To add new data records in the existing data source file, follow these

steps:

1. Open the data source file and then select View→→→→→

Toolbars→→→→→Database command on the menu bar.  The Database

toolbar will appear on the screen.

2. Click on Data Form button.  The Word will display the data

source in the Data Form dialog box.

3. Click Add New button.

4. To fill in a record, type information for a data field, and then

press ENTER to move to the next field.

5. Repeat steps 3 and 4 for each new record.

6. When you finish adding records, click View Source on the Data

Form dialog box, and then click Save on the Standard toolbar.

11.5.4 Add New Data Fields to an Existing Data Source File

To add new data fields in the existing data source file, follow these

steps:

1. Open the data source file and then select View→→→→→Toolbars→→→→→

Database commands from menu bar.  The Database toolbar will

appear on the screen.

2. Click on Manage Fields  button.  The Word will display the

data source in the Data Form dialog box.

3. In the Field name box, type a name for

the new data field, and then click Add.

When you finish adding fields, click OK.

4. To add the new field information to each

record, click Data Form, and then edit

the records in the Data Form dialog box.

11.5.5 Creating a Data Source Using Word Table

In fact, the Mail Merge Helper guides you step by step through

Fig. 11.9
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setting up a Word table that contains your names, addresses, and

other data. Instead of taking advantage of Mail Merge Helper, you

can also create a data source by entering field names and data

directly in a Word table.  Follow these steps to do this:

1. Insert a table by selecting Table→→→→→Insert→→→→→Table command on

the menu bar as explained in an earlier lesson on Tables.

2. Type the data field names on the top row of the table.  Start

typing the data records from the second row.

 EnrolNo Name Add 1 Add 2 City State PIN

 01785679 Ram 13, 7th Main Road Vijaya Nagar Bangalore Karnataka 560040

 01785680 Lakshmi Rampur (Vill), Shadipur (Post) Chittoor (Dist) Andhra Pradesh 571131

 01785681 Renu 85A Pocket-K Sheikh Sarai-II New Delhi 110030

 01785682 Khan 76 Main Road Vidya Nagar Lucknow Uttar Pradesh

3. When you finish entering all the data records, save the table as

a Word document. Your data source document is ready.

11.5.6 Using Excel Worksheet to Create a Data Source

You can use Excel program to create a data source.  Follow these

steps do this.

1. Start Excel program. Open Worksheet.

2. Type the data field names on the top row of the worksheet.

Start typing the data records from the second row.

3. When you finish entering all the data records, save the

worksheet.

4.  Select the data field names and data records you typed in the

worksheet, and then click on Copy button in the standard

toolbar. Close the file and then exit Excel program.

5. Open Word program. Open a new document and then click on

Paste button.  The data will be copied to word document in a

table form.  Save the document.  Your data source document is

ready.

11.6 MERGING DOCUMENTS

Once if you have created your main document and data source docu-
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ment, the next two steps in mail merge are to insert merge fields in

the main document and then merge data in the main document.

You will learn these two steps in this section:

11.6.1 Editing the Main Document and Merging (Inserting)

Fields in the Main Document

To merge the fields in the main document you may have to do some

editing in the main document. Follow these steps to do this:

1. Open the main document.

2. Select Tools→→→→→Mail Merge command on the menu bar.  The

Mail Merge Helper dialog box appears.

3. Under Main document, click Create, and then click Form

Letters.   The Microsoft Word dialog box appears

4. Click Active Window. The active document becomes the main

document.

5. To open the data source document, click

Get Data, and then click Open Data

Source.  The Open Data Source dialog

box will appear.  Choose the data

source file that you have earlier created

and then click Open.  The Microsoft

Word dialog box will appear.  Click Edit

Main Document.  Observe that the

Mail Merge toolbar will appear on the

screen.

6. In the main document, place the cursor where you want to merge

names, addresses, and other data from the data source.  Insert

the merge fields by clicking Insert Merge Field on the Mail

Merge toolbar, and then click the field name you want.   In our

example of student admission letters we have inserted the fields

in the space provided for address of students and enrolment

number.

Fig. 11.10

Fig. 11.11
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7. After you complete the main document and insert all of the

merge fields, click Save As on the File menu. Name the

document, and then click Save.  Now your main document will

work as merge document.

11.6.2 Merging the Data into the Main Document

To merge the data in the main document, follow these steps:

1. Open the merge document.  If the Mail merge toolbar is not on

the screen, select View→→→→→Toolbars→→→→→Mail Merge command on

the menu bar.

2. Click View Merged Data in the Mail Merge toolbar.  The merged

fields will turn to first data record.

3. If you want to see any other merged record, choose the record

number either typing the respective number or clicking the arrow

marks on the Mail Merge toolbar.

11.6.3 Merging the Data and Main Document as a New Document

or to Printer/ Electronic Mail/Fax Using Mail Merge Helper

You can also merge the data records to a new document that can be

used for printing later or to a printer directly for printing or to send

Fig. 11.12
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the merged documents for electronic mailing (or fax) if your computer

has the Internet (or Fax) connections.  To merge the data to a new

document or printer, follow these steps:

1. Open the merge document.  Select Tools→→→→→Mail Merge command

on the menu bar.

2. If you want to specify the

order in which data is

merged, or to merge only

part of the data, then you

can sort and select data

records to merge.

3. Click Merge under Merge

the data with the

document in the Mail

Merge Helper dialog box.

The Merge dialog box will

appear.

4. Check-mark All if you want all records be merged or type the

data range in From and To boxes under Records to be merged.

– Click New document in the drop-down box that appears on

clicking drop-down button under Merge To: in the Merge

dialog box. Click Merge to store the merged letters in a new

document, so that you can review, edit, and print them later.

Save this in one of your folders for future use.

– Click Printer button in the drop-down box that appear on

clicking drop-down button under Merge To: in the Merge

dialog box.  Click Merge to send the selected the merged

letters directly to a printer.   See that the printer is on to

print the letters.

– Click Electronic mail in the drop-down box that appears on

clicking drop-down button under Merge To: in the Merge

dialog box.

– Click Setup.  In the Data field with Mail/Fax address box,

click the data field that contains the e-mail addresses or fax

numbers.

– If you are sending merged documents to e-mail addresses,

do one or more of the following:

 

Fig. 11.13
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o In the Mail message subject line box, type the subject of

your e-mail message.

o If you want to preserve the formatting of a merged document,

select the Send document as an attachment check box. In

this case, Word sends each merged document as a separate

Word document that’s attached to an e-mail message. If this

check box is cleared, Word inserts the text of the resulting

merged document in the e-mail message.

– Click OK.  In the Merge dialog box, click Merge.

11.6.4 Merging the Data and Main Document as a New Document

or to Printer Using Mail Merge Toolbar

You can merge the data records to a new document that can be

used for printing later or to a printer directly for printing or to send

the merged documents for electronic mailing (or fax) if your computer

has the Internet (or Fax) connections.  To merge the data to a new

document or printer, follow these steps using the Mail Merge toolbar:

Open the merge document.  If the Mail merge toolbar is not on the

screen, select View →Toolbars→Mail Merge command on the menu

bar.

l Click Merge to New Document button on the Mail Merge toolbar

to store the merged letters in a new document, so that you can

review, edit, and print them later.

l Click Merge to Printer button on the Mail Merge toolbar to

send all the merged letters directly to a printer.

l Click Merge... button on the Mail Merge toolbar to view Merge

dialog box.  Choose the data range and the document to be

merged (new document or printer or electronic mail), and then

click Merge button on the Merge dialog box.

11.7 CREATING MAILING LABELS BY MERGING

AN ADDRESS LIST

If you have already created a data source (say address list) as ex-

plained earlier, it is easier to merge this address list with your main

document that can be used as mailing labels.  You can do this in 4

steps:
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1. Create the Main Document:

Click New Blank Document on

the Standard toolbar.  Select

Tools→Mail Merge command on

the menu bar.  Under Main

document, click Create, and

then click Mailing Labels.  The

Microsoft Word dialog box ap-

pears.  Click Active Window. The

active document becomes the

main document.

 

2. Open the Data Source:  In the Mail

Merge Helper dialog box, Under Data

source, click Get Data, and then click

Open Data Source. Select the Word

document where you have created

your data source (address list), and

then click Open. The Microsoft Word

dialog box appears.  Click Set Up Main

Document. The Label Options dia-

log box appears.  (If you don’t see the

Label Options dialog box, click anywhere in the main docu-

ment, and then select Tools→→→→→Mail Merge command on the

menu bar. The Mail Merge dialog box appears. Under Main

document, click Setup.  The Label Options dialog box appears.)

3. Select the Label Type and Insert Merge Fields:  In the Label

Options dialog box, Select the type of printer and labels you

want to use, and then click OK. (If the type of labels that you

want to use is not listed in the Product number box, you can

create your own custom labels.) The Create Labels dialog box

appears.

In the Create Labels dialog box, insert merge fields where you

want to merge addresses from the data source. To insert a merge

Fig. 11.14
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field, click Insert Merge Field, and then click the field name

you want. Click OK.   The Mail Merge Dialog box appears.

4. Merge the Data into the Main Document:  In the Mail Merge

Helper dialog box, click Merge under Merge the data with the

document. The Merge dialog box appears.  If you want to send

the merged labels directly to a printer, click Printer in the Merge

to box, and then click Merge.  On the other hand, if you want to

store the merged labels in a new document, (so that you can

review, edit, and print them later) click New Document in the

Merge to box, and then click Merge.

   

11.8 CREATING ENVELOPES BY MERGING AN

 ADDRESS LIST

If you have already created a data source (say address list) as ex-

plained earlier, it is easier to merge this address list with your enve-

lopes so that you can directly print the addresses in the envelopes

(instead of printing the address labels on stickers and then sticking

them on the envelopes) for mailing purpose. You can do this in 4

steps:

1. Create the Main Document:

Click New Blank Document on

the Standard toolbar.  Select

Tools→→→→→Mail Merge command on

the menu bar.  Under Main docu-

ment, click Create, and then

click Envelopes.  The Microsoft

Word dialog box appears.  Click

Active Window. The active docu-

ment becomes the main docu-

ment.

Fig. 11.18 Fig. 11.19
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2. Open the Data Source:  In the Mail Merge Helper dialog box,

Under Data source, click Get Data, and then click Open Data

Source. Select the Word document where you have created your

data source (address list), and then click Open. The Microsoft

Word dialog box appears.  Click Set Up Main Document. The

Envelope Options dialog box appears.  (If you don’t see the

Envelope Options dialog box, click anywhere in the main docu-

ment, and then select Tools→→→→→Mail Merge command on the

menu bar. The Mail Merge dialog box appears. Under Main

document, click Setup.  The Label Options dialog box appears.)

3. Select the Envelope Options and Insert Merge Fields:  On the

Envelope Options tab, select the envelope size you want from a

variety of predefined sizes given under Envelope size: drop down

box, and adjust the address format and position on the envelope.

(If the envelope size that you want to use is not listed in the

Envelope size: box, you can create your own custom envelope

by selecting Custom size under Envelope size: drop down box

in the Envelope Options dialog box.) Click on the Printing

Options tab, and make sure that the selected envelope feed

options are correct for your printer, and then click OK.  The

Envelope address dialog box appears.

Fig. 11.21
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In the Envelope address dialog box, insert merge fields where

you want to merge addresses from the data source. To insert a

merge field, click Insert Merge Field, and then click the field

name you want. Click OK.   The Mail Merge Dialog box appears.

In the Mail Merge Helper dialog box, under Main document,

click Edit, and then click the envelope main document. Type

the return address in an appropriate place by inserting Text

Box that lies on the Drawing toolbar. (If you don’t see the

Drawing toolbar, select View→Toolbars→Drawing command on

the menu bar.  The Drawing toolbar appears). Verify the return

address, or delete it if the envelopes have a pre-printed return

address.

4. Merge the Data into the Main Document:  In the Mail Merge

Helper dialog box, click Merge under Merge the data with the

document. The Merge dialog box appears.  If you want to send

the merged envelopes directly to a printer, click Printer in the

Merge to: box, and then click Merge.  On the other hand, if you

want to store the merged envelopes in a new document, (so that

you can review, edit, and print them later) click New Document

in the Merge to: box, and then click Merge.

Fig. 11.23
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11.9 CREATING A CATALOG

If you have already created a data source (say address list) as ex-

plained earlier, it is easier to merge data to a single document, such

as a catalog, membership directory, etc. You can do this in 4 steps:

1. Create the Main Document: Click New Blank Document on

the Standard toolbar.  Select Tools→Mail Merge command on

the menu bar.  Under Main document, click Create, and then

click Catalog.  The Microsoft Word dialog box appears.  Click

Active Window. The active document becomes the main docu-

ment.

2. Open the Data Source:  In the Mail Merge Helper dialog box,

Under Data source, click Get Data, and then click Open Data

Source. Select the Word document where you have created your

data source (address list), and then click Open. The Microsoft

Word dialog box appears.  Click Edit Main Document.

 

Fig. 11.25
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3. Edit the Main Document and Insert Merge Fields:  In the

main document, type any text that you want to repeat for each

item in the catalog. For example, include labels such as Enrol-

ment Number. At this point, don’t include text (such as head-

ers, footers, and table column headings) that you want to print

only once in the resulting catalog document.

Insert merge fields where you want to merge data from the data

source. To insert a merge field, click in the main document,

click Insert Merge Field on the Mail Merge toolbar, and then

click the field name you want. For example, insert a merge field

after an item label, such as Enrolment Number: «EnrolNo».  Leave

some space (say one or two lines by pressing ENTER key) to

differentiate between two records when they are actually merged

in the main document. After you complete the main document

and insert all of the merge fields, click Save As on the File

menu. Name the document, and then click Save.

4. Merge the Data into the Main Document:  If you don’t see the

Mail Merge toolbar, select View→Toolbars→Mail Merge

command on the menu bar.  The Mail Merge toolbar appears.

Click on Merge to New Document button on the Mail Merge

toolbar.

In the resulting catalog document, add headers, footers, and

any other text that you want. For example, you can add the

heading ‘The List of Students Enrolled for DIT Programme of

Fig. 11.28
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NOS for the Year 2001-2002’. To print the catalog document,

click Print on the Standard toolbar.

INTEXT QUESTIONS

1. What is the difference between main document and merge docu-

ment in Main Merge?

2. In Mail Merge, a data source can be created using —————

or————.

3. You can merge the data records to—————— or ————.

4. To send the merged documents for electronic mailing, it is nec-

essary that your computer has the ————— connection.

5. State True or False

a. Using Word’s Mail Merge features you can merge address

list in a single letter that can be sent to different people but

you cannot insert variable fields in the body text of the let-

ter.

b. It is not possible to send the merged documents for fax with-

out Fax machine connected to your computer.

c. The data records created in a worksheet using Excel cannot

be used as a data source for Mail Merge.

Fig. 11.29
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11.10 WHAT YOU HAVE LEARNT

In this lesson you learnt about the use of mail-merge in MS-Word

environment. Now you can merge a list of names and addresses to a

single letter that can be sent to different people in their names and

address. Secondly, you can create categories, a single letter with

variable information fields in it, or labels. Finally, you can produce

merged documents such as directory lists, invoices and address lists.

These addresses can be printed on envelopes or mailing labels.

11.11 TERMINAL QUESTIONS

1. Briefly explain the following: (a) Main document, (b) Data source,

and (c) Merge document.

2. Write any two features of Mail Merge.

3. Write steps in creating a main document for form letter.

4. Explain steps in editing existing data records in Mail Merge.

5. How do you create a data source using Word table?

6. Write steps in using Excel worksheet as a data source for your

Mail Merge.

11.12 KEY TO INTEXT QUESTIONS

1. In a Mail Merge operation, the personalized document (such as

a letter) is called as the main document.  When you merge the

main document with data source, a third document called merge

document will be produced.

2. Mail Merge Helper or Word Table.

3. A new document or printer.

4. Internet

5. (a)   False, (b)  True, (c) False


