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VISUAL FOXPRO - MENU

SYSTEM

5.1  INTRODUCTION

The Visual FoxPro is a menu driven Relational Database Management

System.  It is easier to communicate with the Visual FoxPro menu

system without programming.  The in-built menu system of the Visual

FoxPro helps the user to work without actually remembering the

command. Visual FoxPro is suitable for multi user environment. It

provides the facility for locking of Records when many users are

simultaneously working on same database.

5.2  OBJECTIVES

After going through this lesson you would be in a position to

l explain the Visual FoxPro Menu System

l work with the various Menu Items of the Visual FoxPro

l explain the functionality of various options of the Toolbar

5.3  FILE MENU

The File menu contains options that permit you to create and save

new files, open and close the existing files, settings for printing

information on the paper, print files, enter printer information and

to exit Visual FoxPro, as shown in Fig. 5.1



Visual FoxPro - Menu System:: 45

Fig. 5.1: File Menu

There are various options available in the File Menu option.  The

description of each option is given below:

Option Description

New… Allows you to create any type of File (Table/DBF,

Program, Index, Report, Label, Form, Menu,

Query Projects, Text File.)

Open… Allows you to open any type of existing files.

Close Closes the current window. If the window’s

contents have changed,  you will be asked to

save the changes.

Save Allows you to store any changes you have made

to the current text, program, label, report, screen,

query, menu or project file without closing the

file.

Save As… Allows you to name and save a newly created

file, or save a copy  of a current file with a new

name.
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Save As Class… Allows you to save a form, or selected controls

on a form, as a class definition. This option is

available when you run the Form Designer.

Save as View… Allows you to save a query into a database (DBC)

file. This option is available when you run the

Query Designer.

Revert Allows you to return to last saved version of file.

Note that the Revert option is only enabled when

you have made changes to a text file, program

file, label file, form file, report file, query file,

menu file, project file or memo field since the

file was last saved.

Import… Allows you to use file from other application

Export… Allows you to use Visual FoxPro file in other

applications.

Print Setup… Allows you to select the printer you want to use

and other several Options about the printer.

Print… Allows you to print only the sources listed below:

- The contents of the Command window.

- The contents of a file that is not currently

open.

- The contents of ASCII file or clipboard.

- The contents of any open editing window.

Page Setup… Allows you to give settings for the page.

Page Preview Allows you to display, the printed image of the

page on the  screen.

Exit Allows you to leave Visual FoxPro and returns

you to the windows desktop. Exit option of File

menu is same as typing Quit in the Command

Window or pressing <Alt+F4> key.

5.4 EDIT MENU

The Edit menu contains options that allow you to edit text in editing

windows as shown in Fig. 5.2. You can also manipulate Object

Linking and Embedding (OLE) objects in Visual FoxPro files.
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Fig. 5.2: Edit Menu

The Edit menu options are described as follows:

Option Description

Undo Allows you to reverse the last action that you have

performed  on any text within a field, record or

file, and in text editing regions in dialogs.

Redo Allows you to restore the last action after it was

undo.

Cut Allows you to remove selection and put it on the

clipboard.

Copy Allows you to copy selection and put it on the

clipboard.

Paste Allows you to place a copy of the clipboard

contents at the current cursor position.

Paste Special… Allows you to place an OLE (Object Linking and

Embedding) object from the clipboard and to

establish a link to its source.

Clear Allows you to remove the selected text, data, or

object without placing it on the clipboard.
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Select  All Allows you to select all objects or all lines of  text,

or all fields in current window.

Find… Allows you to search for specified text.

Replace… Allows you to find and replace specified text.

Goto Line… Allows you to move the cursor to a designated

line in a text, Program or memo editing window,

or in the Command window.

Insert Object… Allows you to place an OLE object on the clipboard

and to establish a link to its source.

Object… Allows you to activate OLE object, to edit the object

or listen to it if it is a sound.

Links… Allows you to edit the link from a source

application to an OLE object in a file.

5.5  VIEW MENU

The View menu displays Reports, Label, and Form designers and

toolbars and allows you to customize the way you work in a table.

Fig. 5.3: View Menu

The View menu options are described as follows:
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Option Description

Toolbars… Allows you to create, edit, hide and customize

toolbars.

Properties… Allows you to display the Properties window

so you can set or change the properties of forms

and controls.  This option is available when

you open the Form or Class Designer.

Browse <table>… Allows you to display the contents of the

current table horizontally in a Browse window.

This option is available when you use a table.

Edit… Allows you to display the contents of the

selected table vertically. This option is available

when you use a table.

Append Mode… Allows you to add new records automatically

to the end of the current table. This option is

available when you use a table.

Database Designer… Allows you to display the Database Designer.

The option is available when you use a table

that is associated with a database.

Table Designer… Allows you to display the Table Designer for

modifying a table’s structure.  This option is

available when you use a table that is

associated with a database.

Grid Lines Allows you to remove or add lines in various

windows. This option is available when you use

a table or open the Label, Report, or Form or

Class Designer.

Design… Allows you to put a new or existing label, report,

or form in design mode. This option is available

when you open the Label, Report, or Form  or

Class Designer.

Tab Order… Allows you to set the tab order for objects on a

form.  This option is available when you run

the Form or Class Designer.

Code… Allows you to display the code window to write,

edit and display event code.  This Option is
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available when you open the Form or Class

Designer.

Form Controls Allows you to display the Form Controls

toolbar, which you

Toolbar… use to create controls on a form. This option is

only available when you open the Form or

Class Designer.

Layout Toolbar… Allows you to display the Layout toolbar, which

you use to align, size, and position controls.

This option is available when you open a Label,

Report, or Form or Class Designer.

Color Palette Allows you to display the Color Palette toolbar,

Toolbar… which you use to specify foreground and

background colors for a control. This option is

available when you open the Label, Report, or

Form or Class Designer.

Show Position… Show in the status bar the position, height,

and width of the selected object in a form,

report, or label.  This option is available when

you open the Label, Report, Form or class

Designer.

Preview… Allows you to display a report or label in a

print preview.  This option is available when

you open the Label or Report Designer.

Report Controls Allows you to display the Report Controls

Toolbar… toolbar which you use to create controls on a

report.  This option is available when you Open

the Label or report Designer.

General Options… Allows you to specify code for an entire menu

system. This option is available when you open

the Menu Designer.

Menu Options… Allows you to specify code for a specific menu.

The option is available when you open the

Menu Designer.

Maximize Top To enlarge the top pane of the Query and View

Pane… Designers.  This option is available when you
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open the Query Designer or View Designer.

Minimize Top To reduce the top pane of the Query and View

Pane… Designers.  This option is available when you

open the Query Designer or View Designer.

Data Environment… Allows you to display the Data Environment

Designer. This optionis available when you

open the Form Designer, Report  Designer, or

Label Designer.

5.6  FORMAT MENU

The Format Menu contains option for fonts, spacing, alignment,

and object positioning, as shown in figure 5.4.

Fig. 5.4: Format Menu

The Format menu options are described as follows:

Option Description

Text Alignment… Allows you to adjust alignment and spacing

of text within a field or label control. This

option is available when you work with a

report or label.
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Fill… Allows you to fill selected control with a

pattern.  This option is available when you

work with a report or label.

Pen… Allows you to set point size and the design

pattern of lines and outlines for rectangles

and rounded rectangles on your label or

report. This option is available when you work

with a report or label.

Mode Determines whether the selected control is

opaque or transparent.  This option is available

when you work with a report or label.

Font… Allows you to select the font type, style and

size.  This option is available when you work

with a text file, field or label control in a report

or label, or the Command Window.

Enlarge Font Allows you to increase the font size by the

next-larger size available. This option is

available when you work with a text or program

file or the command window.

Reduce Font Allows you to decrease the font size by the

next-smaller size available. This option is

available when you work with a text or program

file.

Single Space Allows you to display the text with no blank

lines between lines of text. This option is

available when you work with a text or

program file.

1 ½ Space Allows you to display the text with one-and-

a-half blank lines between lines of text.  This

option is available when you work with a text

or program file.

Double Space Allows you to display the text with two blank

lines between lines of text. This option is

available when you work with a text or program

file.

Indent Allows you to indent the selected line or lines

by one tab.  This  option is available when

you work with a text or program file.
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Remove Indent Allows you to remove previously inserted

indents one at a time. This option is available

when you work with a text or program file.

Align Aligns controls on a form or in a report, label

or class.  This option is available when you

work with a report, label, form, or class.

Size Allows you to change control size.  This option

is available when you work with a report,

label, form, or class, and create and select a

control.

Horizontal Spacing Allows you to set the horizontal spacing of

selected objects.  This option is available when

you work with a report, label, form, or class.

Vertical Spacing Allows you to set the vertical spacing between

selected controls.  This option is available

when you work with a report, label, form, or

class.

Bring To Front Allows you to send selected controls to the

back layer so that any overlapping controls

show up on top of them.  This option is

available when you work with a report, label,

form, or class, add an object or objects, and

select one or more of them.

Send To Back Allows you to send selected controls to the

back layer so that any overlapping controls

show up on top of them.  This option is

available when you work with a report, label,

form, or class, add an object or objects, and

select one or more of them.

Group Allows you to join selected controls so that

they can be manipulated as a single control.

It is equivalent to dragging the mouse to select

all controls at once.  This option is available

when you work with a report or label and

select more than one control.

Ungroup Allows you to separate previously grouped

controls so that they can be manipulated

individually.  This option is available when
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you work with a report, or label, and have

grouped controls.

Snap to Grid Allows you to move controls in grid increments

when you select and drag them.  The option

is available when you work with a report,

label, form, or class, add an object or objects,

and select one or more of them.

Set Grid Scale Allows you to define horizontal and vertical

increments of the grid in pixels, and specifies

whether the ruler displays inches or pixels.

This option is available when you work with a

report, label, form, or class.

5.7  TOOLS MENU

The Tools menu contains options that set system options, run

wizards, create macros, and trace and debug source code, as shown

in Fig. 5.5.

Fig. 5.5: Tools  Menu

The Tools menu options are described as follows:
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Option Description

Wizards Allows you to display a submenu of Visual

FoxPro wizards.

Spelling Allows you to run the spell checker.

Macros.. Allows you to define Key combinations to

perform a series of keystrokes.

Trace Window Allows you to open the Trace Window to watch

program execution.

Debug Window Allows you to open the Debug Window to

monitor the values in programs.

Options… Allows you to set many categories of system

options.

5.8  PROGRAM MENU

The Program menu contains options that are used while

programming in Visual FoxPro, as shown in Figure 5.6

Fig. 5.6: Program Menu
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The Program menu options are described as follows:

Option Description

Do… Allows you to execute a specified program file.

Cancel Allows you to stop a currently running

program.

Resume Allows you to restart execution of a suspended

(not cancelled) program at the line where

execution paused when you choose Trace

option.

Suspend Allows, you to stop running the program, but

keeps it open to resume program execution.

This option is available when you run a

program.

Compile… Allows you to compile the specified program.

5.9  WINDOW MENU

The Window menu contains options that allow you to control

windows, as shown in Fig. 5.7.

Fig. 5.7: Window Menu
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The Window menu options are described below:-

Option Description

Arrange All Allows you to display all open windows in an

arranged fashion so that they don’t overlap.

Hide Allows you to remove the current window from

view, but does not close it.

Hide All Allows you to remove all windows from your

view, but keep them open. This command is

available when you hold down <Shift> Key

while choosing the Window menu.

Show All Allows you to display all open windows.  This

option is available When you hold down

<Shift> Key choosing the window menu.

Clear Allows you to remove the current output

window.  The command equivalent for the

Clear option is to type clear in the command

window.

Cycle Allows you to rearrange open windows to bring

successive ones to the front.  The front most

window moves to the back and the Next

window becomes the front most window.

Command Window Allows you to display the command window.

View Window Allows you to open table files, establish

relation and set work area properties.

1,2,3,…9 Displays the names of all open windows and

allows you to choose from them.

More Windows Allows you to display the More Window dialog

box, in which you select a window to activate.

This option is available when you have more

than nine (9) windows open.

5.10  HELP MENU

The Help menu contains options that open Visual FoxPro online

Help, direct you to technical assistance, and display information

about your computer’s configuration, as shown in figure 5.8.
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Fig. 5.8: Help Menu

The Help menu options are described as follows:

Option Description

Contents Display the Contents panel of Help Window

as shown in figure 5.9. which you can select

and read. You can also display the contents

panel by typing HELP in command window.

Search for Help on… Allows you to search for help topic by typing

or selecting a Keyword.

Technical Support Allows you to display information about

Microsoft Product Support Services and

common questions about Visual FoxPro.

About Microsoft Visual FoxPro… Allows you to display information

about Visual FoxPro and your System as

shown in figure 5.9.
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Fig. 5.9: About Visual FoxPro

INTEXT QUESTIONS

1. In order to open an existing table, which menu option will you

choose?

(a)  Edit Menu (b)  File Menu   (c)  Tools Menu (d)  Help Menu

2. Which command physically removes the records from a table

marked for deletion

(a) Delete (b) Append    (c) Pack (d) Erase

3. Which option of the Edit Menu allows you to insert an OLE

object?

(a) Paste (b) Copy (c) Link (d) Insert object

5.11  DATABASE MENU

The Database menu is added when you open an existing database

or when you create a database schema to define persistent
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relationships among the tables of a relational database (as shown in

figure 5.10).  The database schema contains the logically related

tables, forms, reports, query etc.

The Database menu option are described as follows.

Option Description

New Table Allows you to create a new table using

a wizard or a designer

Add Table Allows you to add an existing table to a

database

New Remote View Allows you to create a new remote view

using a wizard or a designer

New Local View Allows you to create a new local view

using a wizard or a designer

Remove Allows you to remove the selected table

from the database or delete it from the

disk.

Modify Allows you to open the selected table

in the table designer.

Browse Allows you to display the selected table

in the Browse window for editing

Rebuild Table Indexes Allows you to generate keys and rebuild

indexes for the selected table.

Remove Deleted Records Permanently removes all records from

the active table that are marked for

deletion.

Edit Relationship Allows you to modify the relationship

between tables.

Referential Integrity Allows you to display the Referential

Integrity Builder, in which you set up

rules to control how records are

inserted, updated or deleted in related

tables.

Editing stored Procedures Allows you to display a Visual FoxPro

procedure in an editing window.

Clean Up Database Allows you to run the PACK command

to decrease the size of the database by

removing rows that have been marked

for deletion.  The PACK command

physically removes the record from the

table marked for deletion.
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Fig. 5.10: Database Menu

5.12  FORM MENU

The Form menu that is added when you open a form, is used to

create and modify forms ( as shown in figure 5.11) .  The Form menu

options are described as follows:

Option Description

New Property Allows you to create a new property.

New Method Allows you to create a new method.

Edit Property / Method Allows you to edit an existing property

or method. The property or method is

scoped to the standalone form or form

set, as applicable. For a classes, it is

enabled when you add a new property

or method.
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Include File Allow you to specify a reader file of predefined

compile-time constants for a user-defined

class, form, or form set.

Quick Form Allows you to display the Form Builder dialog

box, which helps you to create a simple form

that you can customize by adding your own

controls.

Create Form Allows you to display a new form set, which is

a parent container for one or more forms.

Remove Form Set Allows you to remove an existing form set.

This is applicable only if you have created a

form set.

Run Form Allows you to run a form after you have

designed and saved it.

Fig. 5.11: Form Menu
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5.13  QUERY MENU

The Query menu is added when you work with query.  The Query

menu is used to display selected records and fields of a table in the

desired order.  A Query provides you to retrieves  selected records

based on the selection criteria out of a table in a form which is

convenient to use.  The Query menu contains options that allow you

to create, modify, and run queries ( as shown in figure 5.12).

The Query menu contains options are described as follows:

Option Description

Add Table Allows you to display the Add Table or view

dialog box to add a table or view to the

designer window.

Remove Table Allows you to removes the selected table from

the top pane of the designer window.

Remove Join Allows you to remove the selected join line

from between tables.

Condition

Selection Criteria Allows you to specify the Selection Criteria

tab on top in the Query or View Designer

window.

Output Fields Allows you to specify the Fields tab on top in

the Query or View Designer window.

Order By Allows you to specify the Order By tab on top

in the Query or view Designer window.

Group By Allows you to put the Group By tab on the

top in the Query or View Designer window.

Update Criteria Allows you to put the Update Criteria tab on

top in the View Designer window.

Query Destination Allows you to display the Query Destination

dialog box.  The dialog box allows you to send

the results of your query to eight different

outputs.

View SQL Allows you to display the SQL statement your

query is building
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Advanced Options Allows you to display the Advanced options

dialog box, in which you can fine-tune how

records are retrieved in a view or how updates

are made to the server or source tables.

View Parameters Allows you to set up views that prompt for a

value entry to complete the query.

Comments Allows you to display notes or comments that

you have written to identify the query or view

its purpose.

Run Query To execute the SQL select statement you built,

and send the results to the output destination

you specified.

Fig. 5.12: Query Menu



Visual FoxPro - Menu System:: 65

5.14  REPORT MENU

The Report menu is added when you are working with the designing

of a printed report.  This option is used to create, modify and

customise reports ( as shown in figure 5.13).

The Report Menu contains options are described as follows:

Option Description

Title/Summary Allows you to display the Title/Summary

dialog box, in which you specify the Title and/

or Summary for the report.

Data Grouping Allows you to display the Data Grouping dialog

box to create data groups and Specify their

properties

Variables Allows you to create memory variables within

a report.

Default Font Allows you to specify the persistent fonts. Font

styles, and font sizes for report, Label and

field controls.

Private Data Session Allows you to set the report to have a data

session that does not change if you Open or

use tables in other designers.

Quick Report Allows you to place selected fields

automatically in an empty Report Designer

Window

Run Report Allows you to display the Print dialog box, to

send the report to a printer.
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Fig. 5.13: Report Menu

5.15  TABLE MENU

The Table menu is added when you open a table and is used for

working with data. The Table Menu contains options for examining

and editing the active (selected) table.

The Table menu contains options are described as follows:
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Option Description

Properties Allows you to open the Work Area Properties

dialog box, in which you can modify the

structure of a table, select index files and field,

and define data filters.

Font Allows you to open the Font dialog box, in

which you can specify the font, font style, and

font size that controls the type in a table or

view in the Browse or Edit window.

Go To Record Allows you to positions the record pointer on

the record you specify.

Append New Records Allows you to add record to the end of the

current table.

Toggle Deletion Mark Allows you to place or remove a deletion mark

at the beginning of a selected record to mark

or unmark it for deletion.

Append Records Allows you to open the Append From dialog

box, to add records to the active table from

the another table.

Delete Records Allows you to open the Delete dialog box, in

which you mark records for deletion.

Recall Records Allows you to open the Recall dialog box, in

which you unmark records that are marked

for deletion.

Remove Deleted Records   Allows you to permanently remove records

that are marked for deletion.

Replace Field Allows you to change field information in one

record or in a range of records.

Size Field Allows you to change the width of the selected

field using the Keyboard.

Move Field Allows you to move the selected field using

the Keyboard.

Resize Partitions To activate the window splitter so that you

can partition the window or change the size

of the existing partitions using the keyboard.

Link  Partitions When the Browse window is split, the two

partitions are linked and they scroll vertically

together as you move to different records and

fields. To scroll each partition independently,
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choose the Link Partitions from the Table

menu to remove the check mark(P) to the left

of the option. This option is enabled only when

Browse window is split.

Change Partitions Allows you to move from one partition to

another. This Change Partitions option is

enabled only when the Browse window is

split.

Rebuild Indexes Allows you to rebuild any open index files

associated with the active table so that  they

accurately reflect the current status of the

table.

5.16  STANDARD TOOLBAR

The Standard toolbar contains buttons for performing the most

common actions in Visual  FoxPro. This toolbar is displayed by default

as shown in figure 4.5.

The Standard toolbar contains buttons are described as follows:

Button Description

New Allows you to create new files using designers

and wizards.

Open Allows you to open an existing file or create a

new file.

Save Allows you to save changes to the active file.

Print Allows you to save changes to the active file.

Print Preview Allows you to show you the results of your

work without printing it in WYSIWYG format.

Spelling Allows you to check spelling. Available when

editing text or memo field.

Cut Allows you to remove selected text, controls,

or anything else that is selectable, to the

clipboard.

Copy Allows you to duplicate selected text, controls,

or anything else that is selectable.

Paste Allows you to place cut or copied text, controls,

or anything else that is selectable at the

insertion point position.
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Undo Allows you to reverse the most recent action.

Redo Allows you to reverse the most recent Undo

command.

Run Allows you to run a query, form, or report

after you have designed and saved it.

Database Allows you to specify the current database.

Command Window Allows you to show commands as they are

executed, and provides space for typing

commands.

View Window Allows you to provide an easy way to open

tables, establish relations, and set work area

properties.

Form Wizard Allows you to run a Visual FoxPro form wizard.

Report Wizard Allows you to run a Visual FoxPro report

wizard.

AutoForm Wizard Allows you to create a form without using a

wizard.

AutoReport Wizard Allows you to create a report without using a

wizard.

Help Allows you to display online Help.

5.17 WHAT HAVE YOU LEARNT

In this lesson you have learned about the various options of the

Visual FoxPro Menu Systems.  Now you are in a position to the

functioning of additional Menu System such as Database Menu,

Form Menu, Query Menu, Report Menu and Table Menu.

5.18 TERMINAL QUESTIONS

1. Explain the concept of OLE.

2. Define Database Schema.

3. What is a Query ?

4. Explain Query Menu.

5.19 KEY TO INTEXT QUESTIONS

1. (b)         2.  (c)      3.  (d)


